BiTel

Форум BiTel
bgbilling.ru     docs.bitel.ru     wiki.bitel.ru     dbinfo.bitel.ru     bgcrm.ru     billing.bitel.ru     bitel.ru    
Текущее время: 28 ноя 2021, 14:20

Часовой пояс: UTC + 5 часов [ Летнее время ]




Начать новую тему Ответить на тему  [ Сообщений: 8 ] 
Автор Сообщение
 Заголовок сообщения: Модуль PSB (Промсвязьбанк)
СообщениеДобавлено: 13 авг 2014, 13:57 
Не в сети
Клиент
Аватара пользователя

Зарегистрирован: 27 мар 2012, 11:59
Сообщения: 2644
Откуда: Парагвай
Карма: 69
Подскажите как его настроить? В доке его нет


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Модуль PSB (Промсвязьбанк)
СообщениеДобавлено: 13 авг 2014, 14:20 
Не в сети
Разработчик

Зарегистрирован: 07 апр 2007, 23:51
Сообщения: 4482
Откуда: Уфа, Россия
Карма: 186
в конфигурации есть список параметров


Вложения:
psb_01.png
psb_01.png [ 12.04 КБ | Просмотров: 2704 ]
Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Модуль PSB (Промсвязьбанк)
СообщениеДобавлено: 13 авг 2014, 16:28 
Не в сети
Клиент
Аватара пользователя

Зарегистрирован: 27 мар 2012, 11:59
Сообщения: 2644
Откуда: Парагвай
Карма: 69
а какой URL CGI-скрипта, обрабатывающего уведомления на запросы проведения операций у биллинга?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Модуль PSB (Промсвязьбанк)
СообщениеДобавлено: 13 авг 2014, 21:11 
Не в сети
Разработчик

Зарегистрирован: 07 апр 2007, 23:51
Сообщения: 4482
Откуда: Уфа, Россия
Карма: 186
Код:
http://<host>[:port]/bgbilling/psb/<mid>/


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Модуль PSB (Промсвязьбанк)
СообщениеДобавлено: 14 авг 2014, 04:23 
Не в сети
Клиент
Аватара пользователя

Зарегистрирован: 27 мар 2012, 11:59
Сообщения: 2644
Откуда: Парагвай
Карма: 69
Спасибо!


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Модуль PSB (Промсвязьбанк)
СообщениеДобавлено: 16 апр 2018, 17:55 
Не в сети

Зарегистрирован: 14 фев 2017, 18:55
Сообщения: 9
Карма: 0
День добрый, пришло письмо от ПАО "Промсвязьбанк":

"Коллеги, добрый день!
Изменения в работоспособности ИНТЕРНЕТ-ЭКВАЙРИНГА.
Сообщаем, что с 07,05.2018г. Банк не сможет поддерживать протоколы SSL и TLS 1.0(Transport Layer Security — Протокол защиты транспортного уровня), обеспечивающие безопасность передачу данных от ваших интернет-магазинов на шлюз интернет-эквайринга.
Изменения связаны уязвимостью в безопасности передачи данных при соблюдении требований стандарта PCI DSS.
В избежании проблем с работоспособностью услуги интернет-эквайринг, просьба на вашей стороне обновить версию протокола TLS 1.0 на версии TLS 1.1 и выше.
Извините за доставленные неудобства.
Заранее спасибо.
"

Собственно вопрос, как узнать поддерживает текущий модуль версию TLS 1.1 и выше или нет?
Обновлять модуль не очень хочется, так как присутствуют свои костыли при оплате.

[size=50]Информация о версии:

Клиент: вер. 7.0.843 / 13.10.2016 17:11:35
os: Linux; java: OpenJDK 64-Bit Server VM, v.1.8.0_162
ВНИМАНИЕ: Виртуальная машина OpenJDK 64-Bit Server VM не рекомендуется
ВНИМАНИЕ: версия на сервере: 7.0.895 / 21.06.2017 15:59:45
Сервер: вер. 7.0.1242 / 21.06.2017 16:01:31
os: Linux; java: Java HotSpot(TM) 64-Bit Server VM, v.1.8.0_131

card: вер. 7.0.43 / 21.03.2017 15:12:24
ВНИМАНИЕ: клиентская версия: 7.0.40 / 22.08.2016 16:40:03
inet: вер. 7.0.755 / 21.06.2017 16:02:06
ВНИМАНИЕ: клиентская версия: 7.0.690 / 14.10.2016 19:19:05
mps: вер. 7.0.220 / 06.09.2017 18:56:53
npay: вер. 7.0.207 / 05.06.2017 18:23:51
ВНИМАНИЕ: клиентская версия: 7.0.199 / 05.10.2016 13:38:35
psb: вер. 7.0.49 / 31.01.2017 19:41:52
reports: вер. 7.0.236 / 04.09.2017 14:32:37
ВНИМАНИЕ: клиентская версия: 7.0.220 / 13.10.2016 15:18:11
ru.bitel.bgbilling.plugins.dispatch: вер. 7.0.94 / 04.08.2017 17:34:36
ru.bitel.bgbilling.plugins.documents: вер. 7.0.179 / 03.10.2017 21:41:07
ВНИМАНИЕ: клиентская версия: 7.0.175 / 05.10.2016 13:42:40
uniteller: вер. 7.0.39 / 16.06.2017 11:39:38

Окружение:

Клиент:
os: Linux amd64, 4.4.0-119-generic
java: OpenJDK 64-Bit Server VM, v.1.8.0_162
jre home: /usr/lib/jvm/java-8-openjdk-amd64/jre
memory (use/total/max): 19M/103M/455M
default tz: 16.04.2018 14:35 MSK +0300 (Europe/Moscow)
user tz: 16.04.2018 14:35 MSK +0300 (Europe/Moscow)
locale: ru_RU
Сервер:
os: Linux amd64, 4.4.0-83-generic
java: Java HotSpot(TM) 64-Bit Server VM, v.1.8.0_131
jre home: /opt/java/jdk/jre
default tz: 16.04.2018 14:35 MSK +0300 (Europe/Moscow)
memory (use/total/max): 107M/121M/494M
db time: master: 16.04.2018 14:35 MSK
db charset: connection: utf8(utf8_unicode_ci), database: utf8(utf8_unicode_ci)
locale: ru_RU
uptime: Started: 13.04.2018 19:43:42 Uptime: 2 d 18:51:36

Третьи стороны:

Fugue Icons. Copyright © 2011 Yusuke Kamiyamane. All rights reserved.
http://p.yusukekamiyamane.com/
Silk icon set. Copyright © Mark James. All rights reserved.
http://www.famfamfam.com/lab/icons/silk/
[/size]

_________________

BGBillingServer v 7.0.1129
java version "1.8.0_92"
Java(TM) SE Runtime Environment (build 1.8.0_92-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.92-b14, mixed mode)


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Модуль PSB (Промсвязьбанк)
СообщениеДобавлено: 17 апр 2018, 12:03 
Не в сети
Разработчик

Зарегистрирован: 07 апр 2007, 23:51
Сообщения: 4482
Откуда: Уфа, Россия
Карма: 186
версия TLS определяется используемой версией JDK
в коде модуля это ни как не настраивается


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Модуль PSB (Промсвязьбанк)
СообщениеДобавлено: 17 апр 2018, 12:10 
Не в сети

Зарегистрирован: 14 фев 2017, 18:55
Сообщения: 9
Карма: 0
skn писал(а):
версия TLS определяется используемой версией JDK
в коде модуля это ни как не настраивается


Нейронная сеть "Амир" подсказала, что в JAVA 1.8 проблем вроде как не будет.

_________________

BGBillingServer v 7.0.1129
java version "1.8.0_92"
Java(TM) SE Runtime Environment (build 1.8.0_92-b14)
Java HotSpot(TM) 64-Bit Server VM (build 25.92-b14, mixed mode)


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 8 ] 

Часовой пояс: UTC + 5 часов [ Летнее время ]


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 1


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Перейти:  
POWERED_BY
Русская поддержка phpBB
[ Time : 0.067s | 36 Queries | GZIP : On ]